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Preface

Foreword

Wireshark is the world’s foremost network protocol analyzer, but the rich feature set can be
daunting for the unfamiliar. This document is part of an effort by the Wireshark team to improve
Wireshark’s usability. We hope that you find it useful and look forward to your comments.

Who should read this document?

The intended audience of this book is anyone using Wireshark.

This book explains all of the basic and some advanced features of Wireshark. As Wireshark has
become a very complex program, not every feature may be explained in this book.

This book is not intended to explain network sniffing in general and it will not provide details
about specific network protocols. A lot of useful information regarding these topics can be found at
the Wireshark Wiki at https://wiki.wireshark.org/.

By reading this book, you will learn how to install Wireshark, how to use the basic elements of the
graphical user interface (such as the menu) and what’s behind some of the advanced features that
are not always obvious at first sight. It will hopefully guide you around some common problems
that frequently appear for new (and sometimes even advanced) Wireshark users.
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Typographic Conventions

The following table shows the typographic conventions that are used in this guide.

Table 1. Typographic Conventions

Style Description Example
Italic File names, folder names, and extensions C:|Development|wireshark.
Monospace Commands, flags, and environment CMake’s -G option.
variables
Bold Commands that should be run by the Run cmake -G Ninja ...
Monospace user
[ Button ] Dialog and window buttons Press [ Launch ] to go to the Moon.
Key Keyboard shortcut Press Ctrl + Down to move to the next
packet.
Menu Menu item Select Go » Next Packet to move to the

next packet.
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Admonitions

Important and notable items are marked as follows:

This is a warning

WARNING ] ) ) )
You should pay attention to a warning, otherwise data loss might occur.
This is a caution
CAUTION ) )
Act carefully (i.e., exercise care).
This is important information
IMPORTANT

RTFM - Read The Fine Manual

— This is a tip
Tips are helpful for your everyday work using Wireshark.

This is a note
NOTE . . . . . .
A note will point you to common mistakes and things that might not be obvious.

Shell Prompt and Source Code Examples

Bourne shell, normal user

$ # This is a comment
$ git config --global log.abbrevcommit true

Bourne shell, root user

# # This is a comment
# ninja install

Command Prompt (cmd.exe)

>rem This is a comment
>cd C:\Development

PowerShell

PS$># This is a comment
PS$> choco 1list -1



C Source Code
#include "config.h"

/* This method dissects foos */
static int
dissect_foo_message(tvbuff_t *tvb, packet_info *pinfo _U_, proto_tree *tree _U_, void
*data _U.))
{
/* TODO: implement your dissecting code */
return tvb_captured_length(tvb);



Introduction

What is Wireshark?

Wireshark is a network packet analyzer. A network packet analyzer presents captured packet data
in as much detail as possible.

You could think of a network packet analyzer as a measuring device for examining what’s
happening inside a network cable, just like an electrician uses a voltmeter for examining what’s
happening inside an electric cable (but at a higher level, of course).

In the past, such tools were either very expensive, proprietary, or both. However, with the advent
of Wireshark, that has changed. Wireshark is available for free, is open source, and is one of the
best packet analyzers available today.

Some intended purposes

Here are some reasons people use Wireshark:

* Network administrators use it to troubleshoot network problems
* Network security engineers use it to examine security problems
* QA engineers use it to verify network applications

* Developers use it to debug protocol implementations

* People use it to learn network protocol internals

Wireshark can also be helpful in many other situations.

Features
The following are some of the many features Wireshark provides:

* Available for UNIX and Windows.
» Capture live packet data from a network interface.

* Open files containing packet data captured with tcpdump/WinDump, Wireshark, and many
other packet capture programs.

* Import packets from text files containing hex dumps of packet data.
* Display packets with very detailed protocol information.

* Save packet data captured.

» Export some or all packets in a number of capture file formats.

* Filter packets on many criteria.



Search for packets on many criteria.
* Colorize packet display based on filters.
* Create various statistics.

e ...and a lot more!
However, to really appreciate its power you have to start using it.

Wireshark captures packets and lets you examine their contents. shows Wireshark having captured
some packets and waiting for you to examine them.
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Figure 1. Wireshark captures packets and lets you examine their contents.

Live capture from many different network media

Wireshark can capture traffic from many different network media types, including Ethernet,
Wireless LAN, Bluetooth, USB, and more. The specific media types supported may be limited by
several factors, including your hardware and operating system. An overview of the supported
media types can be found at https://wiki.wireshark.org/CaptureSetup/NetworkMedia.

Import files from many other capture programs

Wireshark can open packet captures from a large number of capture programs. For a list of input
formats see Input File Formats.


https://wiki.wireshark.org/CaptureSetup/NetworkMedia

Export files for many other capture programs

Wireshark can save captured packets in many formats, including those used by other capture
programs. For a list of output formats see Output File Formats.

Many protocol dissectors

There are protocol dissectors (or decoders, as they are known in other products) for a great many
protocols: see Protocols and Protocol Fields.

Open Source Software

Wireshark is an open source software project, and is released under the GNU General Public
License (GPL). You can freely use Wireshark on any number of computers you like, without
worrying about license Kkeys or fees or such. In addition, all source code is freely available under
the GPL. Because of that, it is very easy for people to add new protocols to Wireshark, either as
plugins, or built into the source, and they often do!

What Wireshark is not
Here are some things Wireshark does not provide:

* Wireshark isn’t an intrusion detection system. It will not warn you when someone does strange
things on your network that he/she isn’t allowed to do. However, if strange things happen,
Wireshark might help you figure out what is really going on.

* Wireshark will not manipulate things on the network, it will only “measure” things from it.
Wireshark doesn’t send packets on the network or do other active things (except domain name
resolution, but that can be disabled).

System Requirements

The amount of resources Wireshark needs depends on your environment and on the size of the
capture file you are analyzing. The values below should be fine for small to medium-sized capture
files no more than a few hundred MB. Larger capture files will require more memory and disk
space.

Busy networks mean large captures

A busy network can produce huge capture files. Capturing on even a 100 megabit

NOTE network can produce hundreds of megabytes of capture data in a short time. A
computer with a fast processor, and lots of memory and disk space is always a good
idea.

If Wireshark runs out of memory it will crash. See https://wiki.wireshark.org/KnownBugs/
OutOfMemory for details and workarounds.
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Although Wireshark uses a separate process to capture packets, the packet analysis is single-
threaded and won’t benefit much from multi-core systems.

Microsoft Windows

Wireshark should support any version of Windows that is still within its extended support lifetime.
At the time of writing this includes Windows 11, 10, Server 2022, Server 2019, and Server 2016. It
also requires the following:

* The Universal C Runtime. This is included with Windows 10 and Windows Server 2019 and is
installed automatically on earlier versions if Microsoft Windows Update is enabled. Otherwise
you must install KB2999226 or KB3118401.

* Any modern 64-bit Intel or Arm processor.
* 500 MB available RAM. Larger capture files require more RAM.
* 500 MB available disk space. Capture files require additional disk space.

* Any modern display. 1280 x 1024 or higher resolution is recommended. Wireshark will make
use of HiDPI or Retina resolutions if available. Power users will find multiple monitors useful.

* A supported network card for capturing

o Ethernet. Any card supported by Windows should work. See the wiki pages on Ethernet
capture and offloading for issues that may affect your environment.

o 802.11. See the Wireshark wiki page. Capturing raw 802.11 information may be difficult
without special equipment.

o Other media. See https://wiki.wireshark.org/CaptureSetup/NetworkMedia.
Older versions of Windows which are outside Microsoft’s extended lifecycle support window are no
longer supported. It is often difficult or impossible to support these systems due to circumstances
beyond our control, such as third party libraries on which we depend or due to necessary features
that are only present in newer versions of Windows such as hardened security or memory
management.

* Wireshark 4.2 was the last release branch to officially support Windows 10.

* Wireshark 4.0 was the last release branch to officially support Windows 8.1 and Windows
Server 2012.

* Wireshark 3.6 was the last release branch to officially support 32-bit Windows.

» Wireshark 3.2 was the last release branch to officially support Windows 7 and Windows Server
2008 R2.

* Wireshark 2.2 was the last release branch to support Windows Vista and Windows Server 2008
sans R2

* Wireshark 1.12 was the last release branch to support Windows Server 2003.

* Wireshark 1.10 was the last release branch to officially support Windows XP.
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See the Wireshark release lifecycle page for more details.

macOS

Wireshark supports macOS 11 and later. Similar to Windows, supported macOS versions depend on
third party libraries and on Apple’s requirements.

* Wireshark 4.2 was the last release branch to support macOS 10.14.

* Wireshark 3.6 was the last release branch to support macOS 10.13.

* Wireshark 3.4 was the last release branch to support macOS 10.12.

* Wireshark 2.6 was the last release branch to support Mac OS X 10.6 and 10.7 and OS X 10.8 to
10.11.

* Wireshark 2.0 was the last release branch to support OS X on 32-bit Intel.

* Wireshark 1.8 was the last release branch to support Mac OS X on PowerPC.
See the Wireshark release lifecycle page for more details.

The system requirements should be comparable to the specifications listed above for Windows.

UNIX, Linux, and BSD

Wireshark runs on most UNIX and UNIX-like platforms including Linux and most BSD variants. The
system requirements should be comparable to the specifications listed above for Windows.

Binary packages are available for most Unices and Linux distributions including the following
platforms:

* Alpine Linux

* Arch Linux

* Canonical Ubuntu

* Debian GNU/Linux

* FreeBSD

* Gentoo Linux

* HP-UX

* NetBSD

* OpenPKG

* Oracle Solaris

* Red Hat Enterprise Linux / CentOS / Fedora

If a binary package is not available for your platform you can download the source and try to build
it. Please report your experiences to wireshark-dev[AT]wireshark.org.
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Where To Get Wireshark

You can get the latest copy of the program from the Wireshark website at
https://www.wireshark.org/download.html. The download page should automatically highlight the
appropriate download for your platform and direct you to the nearest mirror. Official Windows
and macOS installers are signed by Wireshark Foundation using trusted certificates on those
platforms. macOS installers are additionally notarized.

A new Wireshark version typically becomes available every six weeks.

If you want to be notified about new Wireshark releases you should subscribe to the wireshark-
announce mailing list. You will find more details in Mailing Lists.

Each release includes a list of file hashes which are sent to the wireshark-announce mailing list and
placed in a file named SIGNATURES-x.y.z.txt. Announcement messages are archived at
https://lists.wireshark.org/archives/wireshark-announce/ and SIGNATURES files can be found at
https://www.wireshark.org/download/src/all-versions/. Both are GPG-signed and include
verification instructions for Windows, Linux, and macOS. As noted above, you can also verify
downloads on Windows and macOS using the code signature validation features on those systems.

A Brief History Of Wireshark

In late 1997 Gerald Combs needed a tool for tracking down network problems and wanted to learn
more about networking so he started writing Ethereal (the original name of the Wireshark project)
as a way to solve both problems.

Ethereal was initially released after several pauses in development in July 1998 as version 0.2.0.
Within days patches, bug reports, and words of encouragement started arriving and Ethereal was
on its way to success.

Not long after that Gilbert Ramirez saw its potential and contributed a low-level dissector to it.

In October, 1998 Guy Harris was looking for something better than tcpview so he started applying
patches and contributing dissectors to Ethereal.

In late 1998 Richard Sharpe, who was giving TCP/IP courses, saw its potential on such courses and
started looking at it to see if it supported the protocols he needed. While it didn’t at that point new
protocols could be easily added. So he started contributing dissectors and contributing patches.

The list of people who have contributed to the project has become very long since then, and almost
all of them started with a protocol that they needed that Wireshark did not already handle. So they
copied an existing dissector and contributed the code back to the team.

In 2006 the project moved house and re-emerged under a new name: Wireshark.

In 2008, after ten years of development, Wireshark finally arrived at version 1.0. This release was
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the first deemed complete, with the minimum features implemented. Its release coincided with the
first Wireshark Developer and User Conference, called Sharkfest.

In 2015 Wireshark 2.0 was released, which featured a new user interface.

In 2023 Wireshark moved to the Wireshark Foundation, a nonprofit corporation that operates
under section 501(c)(3) of the U.S. tax code. The foundation provides the project’s infrastructure,
hosts SharkFest, our developer and user conference, and promotes low level network education.

Development And Maintenance Of Wireshark

Wireshark was initially developed by Gerald Combs. Ongoing development and maintenance of
Wireshark is handled by the Wireshark team, a loose group of individuals who fix bugs and
provide new functionality.

There have also been a large number of people who have contributed protocol dissectors to
Wireshark, and it is expected that this will continue. You can find a list of the people who have
contributed code to Wireshark by checking the about dialog box of Wireshark, or at the authors
page on the Wireshark web site.

Wireshark is an open source software project, and is released under the GNU General Public
License (GPL) version 2. All source code is freely available under the GPL. You are welcome to
modify Wireshark to suit your own needs, and it would be appreciated if you contribute your
improvements back to the Wireshark team.

You gain three benefits by contributing your improvements back to the community:
1. Other people who find your contributions useful will appreciate them, and you will know that

you have helped people in the same way that the developers of Wireshark have helped you.

2. The developers of Wireshark can further improve your changes or implement additional
features on top of your code, which may also benefit you.

3. The maintainers and developers of Wireshark will maintain your code, fixing it when API
changes or other changes are made, and generally keeping it in tune with what is happening
with Wireshark. So when Wireshark is updated (which is often), you can get a new Wireshark
version from the website and your changes will already be included without any additional
effort from you.

The Wireshark source code and binary kits for some platforms are all available on the download
page of the Wireshark website: https://www.wireshark.org/download.html.

Reporting Problems And Getting Help

If you have problems or need help with Wireshark there are several places that may be of interest
(besides this guide, of course).
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Website

You will find lots of useful information on the Wireshark homepage at https://www.wireshark.org/.
Wiki

The Wireshark Wiki at https://wiki.wireshark.org/ provides a wide range of information related to
Wireshark and packet capture in general. You will find a lot of information not part of this user’s
guide. For example, it contains an explanation how to capture on a switched network, an ongoing
effort to build a protocol reference, protocol-specific information, and much more.

And best of all, if you would like to contribute your knowledge on a specific topic (maybe a network
protocol you know well), you can edit the wiki pages with your web browser.

Q&A Site

The Wireshark Q&A site at https://ask.wireshark.org/ offers a resource where questions and
answers come together. You can search for questions asked before and see what answers were
given by people who knew about the issue. Answers are ranked, so you can easily pick out the best
ones. If your question hasn’t been discussed before you can post one yourself.

FAQ

The Frequently Asked Questions lists often asked questions and their corresponding answers.

Read the FAQ

Before sending any mail to the mailing lists below, be sure to read the FAQ. It will
often answer any questions you might have. This will save yourself and others a lot
of time. Keep in mind that a lot of people are subscribed to the mailing lists.

NOTE

You will find the FAQ inside Wireshark by clicking the menu item Help/Contents and selecting the
FAQ page in the dialog shown.

An online version is available at the Wireshark website at https://www.wireshark.org/fag.html. You
might prefer this online version, as it’s typically more up to date and the HTML format is easier to
use.

Mailing Lists
There are several mailing lists of specific Wireshark topics available:

wireshark-announce

Information about new program releases, which usually appear about every six weeks.

wireshark-users

Topics of interest to users of Wireshark. People typically post questions about using Wireshark

12


https://www.wireshark.org/
https://wiki.wireshark.org/
https://ask.wireshark.org/
https://www.wireshark.org/faq.html
https://www.wireshark.org/lists/wireshark-announce
https://www.wireshark.org/lists/wireshark-users

and others (hopefully) provide answers.

wireshark-dev

Topics of interest to developers of Wireshark. If you want to develop a protocol dissector or
update the user interface, join this list.

You can subscribe to each of these lists from the Wireshark web site: https://www.wireshark.org/
lists/. From there, you can choose which mailing list you want to subscribe to by clicking on the
Subscribe/Unsubscribe/Options button under the title of the relevant list. The links to the archives
are included on that page as well.

The lists are archived

TIP You can search in the list archives to see if someone asked the same question some
time before and maybe already got an answer. That way you don’t have to wait until
someone answers your question.

Reporting Problems

Before reporting any problems, please make sure you have installed the latest

NOTE
version of Wireshark.

When reporting problems with Wireshark please supply the following information:

1. The version number of Wireshark and the dependent libraries linked with it, such as Qt or GLib.
You can obtain this from Wireshark’s about box or the command wireshark -v.

2. Information about the platform you run Wireshark on (Windows, Linux, etc. and 32-bit, 64-bit,
etc.).

3. A detailed description of your problem.

4. If you get an error/warning message, copy the text of that message (and also a few lines before
and after it, if there are some) so others may find the place where things go wrong. Please don’t
give something like: “I get a warning while doing x” as this won’t give a good idea where to look.

Don’t send confidential information!

If you send capture files to the mailing lists be sure they don’t contain any
sensitive or confidential information like passwords or personally identifiable

WARNING information (PII).

In many cases you can use a tool like TraceWrangler to sanitize a capture file
before sharing it.

Don’t send large files

NOTE Do not send large files (> 1 MB) to the mailing lists. Instead, provide a download
link. For bugs and feature requests, you can create an issue on GitLab Issues and
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upload the file there.

Reporting Crashes on UNIX/Linux platforms

When reporting crashes with Wireshark it is helpful if you supply the traceback information along
with the information mentioned in “Reporting Problems”.

You can obtain this traceback information with the following commands on UNIX or Linux (note

the backticks):

$ gdb ‘whereis wireshark | cut -f2 -d: | cut -d" ' -f2' core >& backtrace.txt
backtrace
AD

If you do not have gdb available, you will have to check out your operating system’s debugger.

Email backtrace.txt to wireshark-dev[AT]wireshark.org.

Reporting Crashes on Windows platforms

The Windows distributions don’t contain the symbol files (.pdb) because they are very large. You
can download them separately at https://www.wireshark.org/download/win64/all-versions/ .
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Building and Installing Wireshark

Introduction

As with all things there must be a beginning and so it is with Wireshark. To use Wireshark you
must first install it. If you are running Windows or macOS you can download an official release at
https://www.wireshark.org/download.html, install it, and skip the rest of this chapter.

If you are running another operating system such as Linux or FreeBSD you might want to install
from source. Several Linux distributions offer Wireshark packages but they commonly provide out-
of-date versions. No other versions of UNIX ship Wireshark so far. For that reason, you will need to
know where to get the latest version of Wireshark and how to install it.

This chapter shows you how to obtain source and binary packages and how to build Wireshark
from source should you choose to do so.

The general steps are the following:

1. Download the relevant package for your needs, e.g., source or binary distribution.

2. For source distributions, compile the source into a binary. This may involve building and/or
installing other necessary packages.

3. Install the binaries into their final destinations.

Obtaining the source and binary distributions

You can obtain both source and binary distributions from the Wireshark main page or the
download page at https://www.wireshark.org/download.html. Select the package most appropriate
for your system.

Installing Wireshark under Windows

The official Windows packages can be downloaded from the Wireshark main page or the download
page. Installer names contain the version and platform. For example, Wireshark-4.5.0-x64.exe
installs Wireshark 4.5.0 for Windows on 64-bit Intel processors. The Wireshark installer includes
Npcap which is required for packet capture. Windows packages automatically update. See Updating
Wireshark for details.

Simply download the Wireshark installer from https://www.wireshark.org/download.html and
execute it. Official packages are signed by Wireshark Foundation. You can choose to install several
optional components and select the location of the installed package. The default settings are
recommended for most users.
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Installation Components
On the Choose Components page of the installer you can select from the following:

* Wireshark - The network protocol analyzer that we all know and mostly love.
» TShark - A command-line network protocol analyzer. If you haven’t tried it you should.
» External Capture (extcap) - External Capture Interfaces

o Androiddump - Provide capture interfaces from Android devices.

o Etwdump - Provide an interface to read Event Tracing for Windows (ETW) event trace
(ETL).

- Randpktdump - Provide an interface to the random packet generator. (see also randpkt)

o Sshdump, Ciscodump, and Wifidump - Provide remote capture through SSH. (tcpdump,
Cisco EPC, wifi)

- UDPdump - Provide capture interface to receive UDP packets streamed from network
devices.

Additional Tasks

* Wireshark Start Menu Item - Add a shortcut to the start menu.
* Wireshark Desktop Icon - Add a Wireshark icon to the desktop.

» Associate trace file extensions with Wireshark - Associate standard network trace files to
Wireshark.

Install Location

By default Wireshark installs into %ProgramFiles%\Wireshark on 32-bit Windows and
%ProgramFiles64%\Wireshark on 64-bit Windows. This expands to C:\Program Files\Wireshark on
most systems.

Installing Npcap
The Wireshark installer contains the latest Npcap installer.

If you don’t have Npcap installed you won’t be able to capture live network traffic but you will still
be able to open saved capture files. By default the latest version of Npcap will be installed. If you
don’t wish to do this or if you wish to reinstall Npcap you can check the Install Npcap box as
needed.

For more information about Npcap see https://npcap.com/ and https://wiki.wireshark.org/Npcap.

16


https://npcap.com/
https://wiki.wireshark.org/Npcap

Windows installer command line options
For special cases, there are some command line parameters available:
* /S runs the installer or uninstaller silently with default values. The silent installer will not

install Npcap.

» /desktopicon installation of the desktop icon, =yes - force installation, =no - don’t install,
otherwise use default settings. This option can be useful for a silent installer.

/D sets the default installation directory ($INSTDIR), overriding InstallDir and InstallDirRegKey.
It must be the last parameter used in the command line and must not contain any quotes even if
the path contains spaces.

» /NCRC disables the CRC check. We recommend against using this flag.

o /EXTRACOMPONENTS comma separated list of optional components to install. The following extcap
binaries are supported.

o androiddump - Provide interfaces to capture from Android devices
o ciscodump - Provide interfaces to capture from a remote Cisco router through SSH
o randpktdump - Provide an interface to generate random captures using randpkt

o sshdump - Provide interfaces to capture from a remote host through SSH using a remote
capture binary

o udpdump - Provide a UDP receiver that gets packets from network devices

Example:

> Wireshark-4.2.5-x64.exe /NCRC /S /desktopicon=yes /D=C:\Program Files\Foo

> Wireshark-4.2.5-x64.exe /S /EXTRACOMPONENTS=sshdump, udpdump

Running the installer without any parameters shows the normal interactive installer.

Manual Npcap Installation

As mentioned above, the Wireshark installer also installs Npcap. If you prefer to install Npcap
manually or want to use a different version than the one included in the Wireshark installer, you
can download Npcap from the main Npcap site at https://npcap.com/.

Update Npcap

Wireshark updates may also include a new version of Npcap. Manual Npcap updates instructions
can be found on the Npcap web site at https://npcap.com/. You may have to reboot your machine
after installing a new Npcap version.
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Uninstall Wireshark

You can uninstall Wireshark using the Programs and Features control panel. Select the “Wireshark”
entry to start the uninstallation procedure.

The Wireshark uninstaller provides several options for removal. The default is to remove the core
components but keep your personal settings and Npcap. Npcap is kept in case other programs need
it.

Uninstall Npcap

You can uninstall Npcap independently of Wireshark using the Npcap entry in the Programs and
Features control panel. Remember that if you uninstall Npcap you won’t be able to capture
anything with Wireshark.

Building from source under Windows

We strongly recommended using the binary installer for Windows unless you want to start
developing Wireshark on the Windows platform.

For further information how to obtain sources and build Wireshark for Windows from the sources
see the Developer’s Guide at:

* https://www.wireshark.org/docs/wsdg_html_chunked/ChSrcObtain
* https://www.wireshark.org/docs/wsdg_html_chunked/ChSetupWindows

You may also want to have a look at the Development Wiki (https:/wiki.wireshark.org/
Development) for the latest available development documentation.

Installing Wireshark under macOS

The official macOS packages can be downloaded from the Wireshark main page or the download
page. They are signed by Wireshark Foundation. Packages are distributed as disk images (.dmg)
containing the application bundle. Package names contain the platform and version. To install
Wireshark simply open the disk image and drag Wireshark to your /Applications folder. macOS
packages automatically update. See Updating Wireshark for details.

In order to capture packets, you must install the “ChmodBPF” launch daemon. You can do so by
opening the Install ChmodBPF.pkg file in the Wireshark .dmg or from Wireshark itself by opening

Wireshark » About Wireshark selecting the “Folders” tab, and double-clicking “macOS Extras”.

The installer package includes Wireshark along with ChmodBPF and system path packages. See the
included Read me first.html file for more details.
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Installing the binaries under UNIX

In general installing the binary under your version of UNIX will be specific to the installation
methods used with your version of UNIX. For example, under AIX, you would use smit to install the
Wireshark binary package, while under Tru64 UNIX (formerly Digital UNIX) you would use setld.

Installing from RPMs under Red Hat and alike

Building RPMs from Wireshark’s source code results in several packages (most distributions follow
the same system):

* The wireshark package contains the core Wireshark libraries and command-line tools.

* The wireshark or wireshark-qt package contains the Qt-based GUI.

Many distributions use yum or a similar package management tool to make installation of software
(including its dependencies) easier. If your distribution uses yum, use the following command to
install Wireshark together with the Qt GUI:

yum install wireshark wireshark-qt

If you’ve built your own RPMs from the Wireshark sources you can install them by running, for
example:

rpm -ivh wireshark-2.0.0-1.x86_64.rpm wireshark-qt-2.0.0-1.x86_64.rpm

If the above command fails because of missing dependencies, install the dependencies first, and
then retry the step above.

Installing from debs under Debian, Ubuntu and other Debian derivatives

If you can just install from the repository then use
apt install wireshark

Apt should take care of all of the dependency issues for you.

Capturing requires privileges
By installing Wireshark packages non-root, users won’t gain rights automatically to
NOTE capture packets. To allow non-root users to capture packets follow the procedure

described in  https:/gitlab.com/wireshark/wireshark/-/blob/master/packaging/
debian/README.Debian (/usr/share/doc/wireshark-common/README.Debian.gz)
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Installing from portage under Gentoo Linux

Use the following command to install Wireshark under Gentoo Linux with all of the extra features:

USE="c-ares ipvb snmp ssl kerberos threads selinux" emerge wireshark

Installing from packages under FreeBSD

Use the following command to install Wireshark under FreeBSD:
pkg_add -r wireshark

pkg_add should take care of all of the dependency issues for you.

Building from source under UNIX or Linux

We recommended using the binary installer for your platform unless you want to start developing
Wireshark.

Building Wireshark requires the proper build environment including a compiler and many
supporting libraries. For more information, see the Developer’s Guide at:

* https://www.wireshark.org/docs/wsdg_html_chunked/ChSrcObtain

* https://www.wireshark.org/docs/wsdg_html_chunked/ChapterSetup#ChSetupUNIX

Updating Wireshark

By default, Wireshark on Windows and macOS will check for new versions and notify you when
they are available. If you have the Check for updates preference disabled or if you run Wireshark in
an isolated environment you should subscribe to the wireshark-announce mailing list to be notified
of new versions. See Mailing Lists for details on subscribing to this list.

New versions of Wireshark are usually released every four to six weeks. Updating Wireshark is
done the same way as installing it. Simply download and run the installer on Windows, or
download and drag the application on macOS. A reboot is usually not required and all your
personal settings will remain unchanged.

We offer two update channels, Stable and Development. The Stable channel is the default, and only
installs packages from stable (even-numbered) release branches. The Development channel installs
development and release candidate packages when they are available, and stable releases
otherwise. To configure your release channel, go to Preferences » Advanced and search for
“update.channel”. See Preferences for details.
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User Interface

Introduction

By now you have installed Wireshark and are likely keen to get started capturing your first packets.
In the next chapters we will explore:

* How the Wireshark user interface works

* How to capture packets in Wireshark

* How to view packets in Wireshark

* How to filter packets in Wireshark

¢ ... and many other things!

Start Wireshark

You can start Wireshark from your shell or window manager.

Power user tip

TIP When starting Wireshark it’s possible to specify optional settings using the command
line. See Start Wireshark from the command line for details.

The following chapters contain many screenshots of Wireshark. As Wireshark runs on many
different platforms with many different window managers, different styles applied and there are
different versions of the underlying GUI toolkit used, your screen might look different from the
provided screenshots. But as there are no real differences in functionality these screenshots should
still be well understandable.

The Main window

Let’s look at Wireshark’s user interface. The Main window shows Wireshark as you would usually
see it after some packets are captured or loaded (how to do this will be described later).
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Figure 2. The Main window

Wireshark’s main window consists of parts that are commonly known from many other GUI
programs.
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The menu (see The Menu) is used to start actions.

The main toolbar (see The “Main” Toolbar) provides quick access to frequently used items from
the menu.

The filter toolbar (see The “Filter” Toolbar) allows users to set display filters to filter which
packets are displayed (see Filtering Packets While Viewing).

The packet list pane (see The “Packet List” Pane) displays a summary of each packet captured. By
clicking on packets in this pane you control what is displayed in the other two panes.

The packet details pane (see The “Packet Details” Pane) displays the packet selected in the packet
list pane in more detail.

The packet bytes pane (see The “Packet Bytes” Pane) displays the data from the packet selected in
the packet list pane, and highlights the field selected in the packet details pane.

The packet diagram pane (see The “Packet Diagram” Pane) displays the packet selected in the
packet list as a textbook-style diagram.

The statusbar (see The Statusbar) shows some detailed information about the current program
state and the captured data.

TIP The layout of the main window can be customized by changing preference settings.



See Preferences for details.

Main Window Navigation

Packet list and detail navigation can be done entirely from the keyboard. Keyhoard Navigation
shows a list of keystrokes that will let you quickly move around a capture file. See Go menu items
for additional navigation keystrokes.

Table 2. Keyboard Navigation

Accelerator Description

Tab or Shift + Tab Move between screen elements, e.g., from the toolbars to the packet list to
the packet detail.

¢ Move to the next packet or detail item.

1 Move to the previous packet or detail item.

Ctrl + { or F8 Move to the next packet, even if the packet list isn’t focused.

Ctrl + 1T or F7 Move to the previous packet, even if the packet list isn’t focused.

Ctrl + . Move to the next packet of the conversation (TCP, UDP or IP).

Ctrl + , Move to the previous packet of the conversation (TCP, UDP or IP).

Alt + » or Option + > Move to the next packet in the selection history.
(macOS)

Alt + « or Option + ¢« Move to the previous packet in the selection history.
(macOS)

& In the packet detail, closes the selected tree item. If it’s already closed,
jumps to the parent node.

i In the packet detail, opens the selected tree item.

Shift + - In the packet detail, opens the selected tree item and all of its subtrees.
Ctrl +» In the packet detail, opens all tree items.

Ctrl + « In the packet detail, closes all tree items.

Backspace In the packet detail, jumps to the parent node.

Return or Enter In the packet detail, toggles the selected tree item.

Help > About Wireshark » Keyboard Shortcuts will show a list of all shortcuts in the main
window. Additionally, typing anywhere in the main window will start filling in a display filter.

The Menu

Wireshark’s main menu is located either at the top of the main window (Windows, Linux) or at the
top of your main screen (macOS). An example is shown in The Menu.
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Some menu items will be disabled (greyed out) if the corresponding feature isn’t
NOTE available. For example, you cannot save a capture file if you haven’t captured or
loaded any packets.

File Edit View Go  Capture  Analyze Statistics  Telephony  Wireless  Tocls  Help

Figure 3. The Menu
The main menu contains the following items:

File
This menu contains items to open and merge capture files, save, print, or export capture files in
whole or in part, and to quit the Wireshark application. See The “File” Menu.

Edit
This menu contains items to find a packet, time reference or mark one or more packets, handle
configuration profiles, and set your preferences; (cut, copy, and paste are not presently
implemented). See The “Edit” Menu.

View
This menu controls the display of the captured data, including colorization of packets, zooming

the font, showing a packet in a separate window, expanding and collapsing trees in packet
detalils, .... See The “View” Menu.

Go

This menu contains items to go to a specific packet. See The “Go” Menu.

Capture

This menu allows you to start and stop captures and to edit capture filters. See The “Capture”
Menu.

Analyze

This menu contains items to manipulate display filters, enable or disable the dissection of
protocols, configure user specified decodes and follow a TCP stream. See The “Analyze” Menu.

Statistics

This menu contains items to display various statistic windows, including a summary of the
packets that have been captured, display protocol hierarchy statistics and much more. See The
“Statistics” Menu.

Telephony

This menu contains items to display various telephony related statistic windows, including a
media analysis, flow diagrams, display protocol hierarchy statistics and much more. See The
“Telephony” Menu.
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Wireless

This menu contains items to display Bluetooth and IEEE 802.11 wireless statistics.

Tools

This menu contains various tools available in Wireshark, such as creating Firewall ACL Rules.
See The “Tools” Menu.

Help

This menu contains items to help the user, e.g., access to some basic help, manual pages of the
various command line tools, online access to some of the webpages, and the usual about dialog.
See The “Help” Menu.

Each of these menu items is described in more detail in the sections that follow.

Shortcuts make life easier

TP Most common menu items have keyboard shortcuts. For example, you can press the

Control and the K keys together to open the “Capture Options” dialog.

The “File” Menu

The Wireshark file menu contains the fields shown in File menu items.
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Figure 4. The “File” Menu
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Table 3. File menu items
Menu Item

Open...

Open Recent

Merge...

Import from Hex Dump...

Close

Save

Save As...
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Accelerator

Ctr1 + 0

Ctrl + W

Ctrl + S

Shift + Ctrl + S

Description

This shows the file open dialog box that allows
you to load a capture file for viewing. It is
discussed in more detail in The “Open Capture
File” Dialog Box.

This lets you open recently opened capture files.
Clicking on one of the submenu items will open
the corresponding capture file directly.

This menu item lets you merge a capture file
into the currently loaded one. It is discussed in
more detail in Merging Capture Files.

This menu item brings up the import file dialog
box that allows you to import a text file
containing a hex dump into a new temporary
capture. It is discussed in more detail in Import
Hex Dump.

This menu item closes the current capture. If
you haven’t saved the capture, you will be asked
to do so first (this can be disabled by a
preference setting).

This menu item saves the current capture. If you
have not set a default capture file name
(perhaps with the -w <capfile> option),
Wireshark pops up the Save Capture File As
dialog box (which is discussed further in The
“Save Capture File As” Dialog Box).

If you have already saved the current capture,
this menu item will be greyed out.

You cannot save a live capture while the capture
is in progress. You must stop the capture in
order to save.

This menu item allows you to save the current
capture file to whatever file you would like. It
pops up the Save Capture File As dialog box
(which is discussed further in The “Save Capture
File As” Dialog Box).



Menu Item Accelerator

File Set > List Files

File Set » Next File

File Set > Previous File

Export Specified Packets...

Export Packet Ctrl +H
Dissections...

Export Objects

Print... Ctr1 + P
Quit Ctrl +Q

The “Edit” Menu

Description

This menu item allows you to show a list of files
in a file set. It pops up the Wireshark List File Set
dialog box (which is discussed further in File
Sets).

If the currently loaded file is part of a file set,
jump to the next file in the set. If it isn’t part of a
file set or just the last file in that set, this item is
greyed out.

If the currently loaded file is part of a file set,
jump to the previous file in the set. If it isn’t part
of a file set or just the first file in that set, this
item is greyed out.

This menu item allows you to export all (or
some) of the packets in the capture file to file. It
pops up the Wireshark Export dialog box (which
is discussed further in Exporting Data).

These menu items allow you to export the
currently selected bytes in the packet bytes pane
to a text file in a number of formats including
plain, CSV, and XML. It is discussed further in
The “Export Selected Packet Bytes” Dialog Box.

These menu items allow you to export captured
DICOM, FTP-DATA, HTTP, IMF, SMB, or TFTP
objects into local files. It pops up a
corresponding object list (which is discussed
further in The “Export Objects” Dialog Box)

This menu item allows you to print all (or some)
of the packets in the capture file. It pops up the
Wireshark Print dialog box (which is discussed
further in Printing Packets).

This menu item allows you to quit from
Wireshark. Wireshark will ask to save your
capture file if you haven’t previously saved it
(this can be disabled by a preference setting).

The Wireshark Edit menu contains the fields shown in Edit menu items.
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Figure 5. The “Edit” Menu

Table 4. Edit menu items

Menu Item Accelerator

Copy

Find Packet... Ctr1 + F

Find Next Ctr1 + N

Find Previous Ctrl + B

Mark/Unmark Selected CtrL + M

Mark All Displayed Packets Ctrl + Shift + M

Unmark All Displayed Ctrl + ALt + M

Packets

Next Mark Ctrl + Shift + N
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Description

These menu items will copy the packet list,
packet detail, or properties of the currently
selected packet to the clipboard.

This menu item brings up a toolbar that allows
you to find a packet by many criteria. There is
further information on finding packets in
Finding Packets.

This menu item tries to find the next packet
matching the settings from “Find Packet...”.

This menu item tries to find the previous packet
matching the settings from “Find Packet...”.

This menu item marks the currently selected
packet. See Marking Packets for details.

This menu item marks all displayed packets.

This menu item unmarks all displayed packets.

Find the next marked packet.



Menu Item
Previous Mark
Ignore/Unignore Selected

Ignore All Displayed

Unignore All Displayed

Set/Unset Time Reference

Unset All Time References

Next Time Reference

Previous Time Reference

Time Shift...

Packet Comment...

Delete All Packet
Comments

Inject TLS Secrets

Accelerator

Ctrl + Shift + B

Ctr1 + D

Ctrl + Shift + D

Ctrl + A1t + D
Ctr1 + T

Ctrl + ALt + T

Ctrl + A1t + N

Ctrl + ALt + B

Ctrl + Shift + T

Ctrl + ALt + C

Description
Find the previous marked packet.

This menu item marks the currently selected
packet as ignored. See Ignoring Packets for
details.

This menu item marks all displayed packets as
ignored.

This menu item unmarks all ignored packets.

This menu item set a time reference on the
currently selected packet. See Packet Time
Referencing for more information about the
time referenced packets.

This menu item removes all time references on
the packets.

This menu item tries to find the next time
referenced packet.

This menu item tries to find the previous time
referenced packet.

Opens the “Time Shift” dialog, which allows you
to adjust the timestamps of some or all packets.

Opens the “Packet Comment” dialog, which lets
you add a comment to a single packet. Note that
the ability to save packet comments depends on
your file format. E.g., pcapng supports
comments, pcap does not.

This will delete all comments from all packets.
Note that the ability to save capture comments
depends on your file format. E.g., pcapng
supports comments, pcap does not.

Embeds the used TLS decryption secrets into the
capture file, which lets TLS be decrypted
without having the separate keylog file. Note
that the ability to save decryption secrets
depends on your file format. E.g., pcapng
supports Decryption Secrets Blocks, pcap does
not.
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Menu Item

Discard All Secrets

Configuration Profiles...

Preferences...

Accelerator

Ctrl + Shift + A

Description

This will discard all embedded decryption
secrets from the capture file. Note that the
ability to save decryption secrets depends on
your file format. E.g., pcapng supports
Decryption Secrets Blocks, pcap does not.

This menu item brings up a dialog box for
handling configuration profiles. More detail is
provided in Configuration Profiles.

Ctrl + Shift + P or This menu item brings up a dialog box that
Cmd + , (macOS)

The “View” Menu

allows you to set preferences for many
parameters that control Wireshark. You can also
save your preferences so Wireshark will use
them the next time you start it. More detail is
provided in Preferences.

The Wireshark View menu contains the fields shown in View menu items.
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Figure 6. The “View” Menu

Table 5. View menu items
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Menu Item

Main Toolbar

Filter Toolbar

Wireless Toolbar

Statusbar

Packet List

Packet Details

Packet Bytes

Packet Diagram

Time Display Format »
Date and Time of Day:
1970-01-01 01:02:03.123456

Time Display Format »
Time of Day:
01:02:03.123456

Time Display Format >
Seconds Since Epoch (1970-
01-01): 1234567890.123456

Time Display Format »
Seconds Since First
Captured Packet:
123.123456

Accelerator

Description

This menu item hides or shows the main toolbar,
see The “Main” Toolbar.

This menu item hides or shows the filter toolbar,
see The “Filter” Toolbar.

This menu item hides or shows the wireless
toolbar. May not be present on some platforms.

This menu item hides or shows the statusbar,
see The Statusbar.

This menu item hides or shows the packet list
pane, see The “Packet List” Pane.

This menu item hides or shows the packet
details pane, see The “Packet Details” Pane.

This menu item hides or shows the packet bytes
pane, see The “Packet Bytes” Pane.

This menu item hides or shows the packet
diagram pane. See The “Packet Diagram” Pane.

Selecting this tells Wireshark to display the time
stamps in date and time of day format, see Time
Display Formats And Time References.

The fields “Time of Day”, “Date and Time of
Day”, “Seconds Since First Captured Packet”,
“Seconds Since Previous Captured Packet” and
“Seconds Since Previous Displayed Packet” are
mutually exclusive.

Selecting this tells Wireshark to display time
stamps in time of day format, see Time Display
Formats And Time References.

Selecting this tells Wireshark to display time
stamps in seconds since 1970-01-01 00:00:00, see
Time Display Formats And Time References.

Selecting this tells Wireshark to display time
stamps in seconds since first captured packet
format, see Time Display Formats And Time
References.
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Menu Item

Time Display Format »
Seconds Since Previous
Captured Packet: 1.123456

Time Display Format >
Seconds Since Previous
Displayed Packet: 1.123456

Time Display Format »
Automatic (File Format
Precision)

Time Display Format »
Seconds: 0

Time Display Format» ...
seconds: 0....

Time Display Format »
Display Seconds with
hours and minutes

Name Resolution » Edit
Resolved Name

Name Resolution » Enable
for MAC Layer

Name Resolution » Enable
for Network Layer

Name Resolution > Enable
for Transport Layer
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Accelerator

Description

Selecting this tells Wireshark to display time
stamps in seconds since previous captured
packet format, see Time Display Formats And
Time References.

Selecting this tells Wireshark to display time
stamps in seconds since previous displayed
packet format, see Time Display Formats And
Time References.

Selecting this tells Wireshark to display time
stamps with the precision given by the capture
file format used, see Time Display Formats And
Time References.

The fields “Automatic”, “Seconds” and “...
seconds” are mutually exclusive.

Selecting this tells Wireshark to display time
stamps with a precision of one second, see Time
Display Formats And Time References.

Selecting this tells Wireshark to display time
stamps with a precision of one second,
decisecond, centisecond, millisecond,
microsecond or nanosecond, see Time Display
Formats And Time References.

Selecting this tells Wireshark to display time
stamps in seconds, with hours and minutes.

This item allows you to manually enter names to
resolve IP addresses in the current packet, see
Name Resolution.

This item allows you to control whether or not
Wireshark translates MAC addresses into names,
see Name Resolution.

This item allows you to control whether or not
Wireshark translates network addresses into
names, see Name Resolution.

This item allows you to control whether or not
Wireshark translates transport addresses into
names, see Name Resolution.



Menu Item

Zoom In

Zoom Out

Normal Size

Expand Subtrees

Collapse Subtrees

Expand All

Collapse All

Colorize Packet List

Colorize Conversation

Colorize Conversation »

Color 1-10

Colorize Conversation »

Reset coloring

Colorize Conversation »
New Coloring Rule...

Accelerator

Ctrl + +

Ctrl + -

Ctrl + =

Shift + >

Shift + «

Ctrl + »

Ctrl + ¢«

Description

Zoom into the packet data (increase the font
size).

Zoom out of the packet data (decrease the font
size).

Set zoom level back to 100% (set font size back to
normal).

This menu item expands the currently selected
subtree in the packet details tree.

This menu item collapses the currently selected
subtree in the packet details tree.

Wires